Update rate and delay

dwm1001
#1

Hi,
I have a DW kit with R2 so I have gateway, my point is if I decrease the update rate so I will save a lot of power, the tag track will delay so it will not give me the last position, it will move slow, but if I use 10Hz everything good and the tags move smoothly, any advice on this please?

0 Likes

#2

Hi,
Not sure what you are describing?
Have you also adjust the stationary update rate?
Ken

0 Likes

#3

I think he is referring to that when he moves using a slower update rate the tag doesn’t give the actual position of where it is when it updates, instead it’s lagging behind. I have seen it happen as well.

Say I move the tag 10 meters in X axis very quickly and use a slow update rate. Instead of giving me the 10 meter position when I move the tag, first it reports 2 meters, then on the next update cycle 4 meters etc. until it reaches the 10 meters.

I guess this has something to do with the filters and moving average implemented in the location algorithm.

1 Like

#4

Thank you @dpelaez, you described it well, I tried to adjust the update rate as a minimum I could also with a good moving I put 5Hz for normal update rate and 2Hz for stationary update rate, it is not bad, but lower than this a very big delay will happen.
@Kenneth_Dwyer_DW

0 Likes

#5

Hi All,
any comments, please?

0 Likes

#6

Hi,

if you use DRTLS Web Manager, you can disable position average to reduce the latency.

Cheers,
TDK

0 Likes

#7

Thank you @leapslabs , it is better now after I disable position average,
if I could do some other things will be good also if you know, please.
thank you.

0 Likes

#8

Is there anyway to do this through the API?

0 Likes

#9

I noticed the accelerometer can have have some delays to detect movement. Try disabling “Stationary detection” on the tag.

0 Likes